Jump to content
  • Announcements

    • admin

      PBS Forum Has Closed   06/12/17

      The PBS Works Support Forum is no longer active.  For PBS community-oriented questions and support, please join the discussion at http://community.pbspro.org.  Any new security advisories related to commercially-licensed products will be posted in the PBS User Area (https://secure.altair.com/UserArea/). 
Sign in to follow this  
CSCFCEM

PBS queue not using set exclusive nodes

Recommended Posts

So while trying to configure some queues for another problem (http://forum.pbsworks.com/index.php?/topic/631-pbs-queue-for-limited-walltime-and-exclusive-nodes/), I seem to have hit some unexpected behavior.  I was attempting to assign exclusive nodes to a queue.  The system I use has 32 cores, on 4 nodes.  I want our "small" queue to use 2 nodes.  Our server has the nodes listed as server[0], server[1], server[2], and server[3].  We have a route queue (as default queue) set up as well to use the small queue.


 


What we tried was this (following from examples seen in the linked problem and elsewhere):


 


set node server[0] queue = small


set node server[1] queue = small


 


I assigned a walltime limit (max of 8 hours) for this queue as well.


 


I then submitted 3 jobs without specifying the queue (only walltime) and the following happened:


 


job1 (<8 hours requested walltime)  ---> immediately runs on small queue on node server[3]


job2 (>8 hours requested walltime) ---> immediately runs on other queue on node server[2]


job3 (<8 hours requested walltime) ---> not enough resources, job is queued


 


I was expecting job1 to go to small queue on node server[0] or server[1], and I'd expect job3 to as well.  It is as if the set node command has blocked me from assigning any jobs to those nodes. 


 


Any idea as to what went wrong?


Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

×